summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-02-21 20:40:07 +0100
committerChuck Miller <shadowmil@gmail.com>2010-02-21 17:05:40 -0500
commitc8b0d1e56f27c3141895d28b2fc768afffe7bb2d (patch)
tree0a03458836badee3e1b0da13a0721c9261e7fa86 /src/CMakeLists.txt
parent204a14c91bbe4436eb3b26bebf30cbe5669bdd1a (diff)
downloadmana-client-c8b0d1e56f27c3141895d28b2fc768afffe7bb2d.tar.gz
mana-client-c8b0d1e56f27c3141895d28b2fc768afffe7bb2d.tar.bz2
mana-client-c8b0d1e56f27c3141895d28b2fc768afffe7bb2d.tar.xz
mana-client-c8b0d1e56f27c3141895d28b2fc768afffe7bb2d.zip
Made tick counter and framerate limiter work during login sequence
Much code was moved from main() to the new Client::exec(). This new event loop now integrates with the Game class, so that the tick counter and framerate limiter apply universally. The Client class is also responsible for some things that used to be global variables. Mantis-issue: ...
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1273fe40..4f90d0a2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -396,6 +396,8 @@ SET(SRCS
being.h
beingmanager.cpp
beingmanager.h
+ client.cpp
+ client.h
channel.cpp
channel.h
channelmanager.cpp