summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsniper <sniper@livecd.janhome.net>2009-03-11 15:35:54 +0100
committerIra Rice <irarice@gmail.com>2009-03-12 21:25:27 -0600
commit7d20381b7b9abdf0934ee0fbbb196c788ea93a0d (patch)
tree72e0eef30733d2928d9c0cf41090d3ea10a82e4f /src/CMakeLists.txt
parent393c1085ed1cb24092778594d2945a39428e41ad (diff)
downloadmana-client-7d20381b7b9abdf0934ee0fbbb196c788ea93a0d.tar.gz
mana-client-7d20381b7b9abdf0934ee0fbbb196c788ea93a0d.tar.bz2
mana-client-7d20381b7b9abdf0934ee0fbbb196c788ea93a0d.tar.xz
mana-client-7d20381b7b9abdf0934ee0fbbb196c788ea93a0d.zip
Extending the internal handling of colors
The internal storage for colors was in the file color.h/color.cpp. It mainly managed the colors in the chat. The Color class was extended to be more generic now and it stores gcn::Color objects instead of integers now. A lot of new colortypes are now available, though not many of them are used for now, that will come in the next patches. The Color class was renamed to Palette and color.{h,cpp} to palette.{h,cpp} to better describe its purpose. The color config gui now lists the new colors, even changes them, but the result is not displayed properly for now.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9fdca23a..6565a1b0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -81,8 +81,6 @@ SET(SRCS
gui/chatinput.h
gui/checkbox.cpp
gui/checkbox.h
- gui/color.cpp
- gui/color.h
gui/confirm_dialog.cpp
gui/confirm_dialog.h
gui/connection.cpp
@@ -140,6 +138,8 @@ SET(SRCS
gui/npc_text.h
gui/ok_dialog.cpp
gui/ok_dialog.h
+ gui/palette.cpp
+ gui/palette.h
gui/passwordfield.cpp
gui/passwordfield.h
gui/playerbox.cpp
@@ -205,6 +205,7 @@ SET(SRCS
gui/textbox.h
gui/textfield.cpp
gui/textfield.h
+ gui/textrenderer.h
gui/trade.cpp
gui/trade.h
gui/truetypefont.cpp