summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorIra Rice <irarice@gmail.com>2009-01-15 19:48:00 -0700
committerIra Rice <irarice@gmail.com>2009-01-15 19:48:00 -0700
commit0a18932056e2a72f41cdd14c831344ad80cfb35b (patch)
tree9b3592df7749831be8d3e8bd5a8c04f6d1217c90 /src/CMakeLists.txt
parent731dcee8bec7e32d576b0e6a9d98b9a21050362e (diff)
downloadmana-client-0a18932056e2a72f41cdd14c831344ad80cfb35b.tar.gz
mana-client-0a18932056e2a72f41cdd14c831344ad80cfb35b.tar.bz2
mana-client-0a18932056e2a72f41cdd14c831344ad80cfb35b.tar.xz
mana-client-0a18932056e2a72f41cdd14c831344ad80cfb35b.zip
Added emote database, which is loosely based off of the NPC database.
Also changed all emotes to be animated sprites now, and to load from emotes.xml. This gives us a bit more flexibility to not only add more emotes in the future, but allowing them to be animated as well. NOTE: This commit, unlike the previous emote commits, breaks emotes if you don't have the xml file. This will be available on Aethyra soon, but is not rolled into an update at the moment. Signed-off-by: Ira Rice <irarice@gmail.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 657d8e6b..dbdd64b6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -233,6 +233,8 @@ SET(SRCS
resources/colordb.h
resources/dye.cpp
resources/dye.h
+ resources/emotedb.cpp
+ resources/emotedb.h
resources/image.cpp
resources/image.h
resources/imageloader.cpp