summaryrefslogtreecommitdiff
path: root/packaging/debian/rules
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2008-12-26 17:39:13 +0100
committerBjørn Lindeijer <bjorn@lindeijer.nl>2008-12-26 17:39:13 +0100
commit6258015e48b1c612bd96b232b47ca560e4e84f00 (patch)
tree7986d18491025219b052bb67954826337dc185fe /packaging/debian/rules
parent7835e9afe3a493b27906b62aaa003c38d09b8114 (diff)
downloadmana-client-6258015e48b1c612bd96b232b47ca560e4e84f00.tar.gz
mana-client-6258015e48b1c612bd96b232b47ca560e4e84f00.tar.bz2
mana-client-6258015e48b1c612bd96b232b47ca560e4e84f00.tar.xz
mana-client-6258015e48b1c612bd96b232b47ca560e4e84f00.zip
Moved debian packaging scripts to packaging directory
Diffstat (limited to 'packaging/debian/rules')
-rw-r--r--packaging/debian/rules69
1 files changed, 69 insertions, 0 deletions
diff --git a/packaging/debian/rules b/packaging/debian/rules
new file mode 100644
index 00000000..614ee701
--- /dev/null
+++ b/packaging/debian/rules
@@ -0,0 +1,69 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+include /usr/share/dpatch/dpatch.make
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+config.status: patch
+ dh_testdir
+ CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+ --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
+ --datadir=/usr/share/games --bindir=/usr/games --mandir=/usr/share/man
+
+build: build-stamp
+build-stamp: config.status
+ dh_testdir
+ $(MAKE)
+ touch build-stamp
+
+clean: unpatch
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+ [ ! -f Makefile ] || $(MAKE) distclean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+binary-indep: build install
+ dh_testdir -i
+ dh_testroot -i
+ dh_installchangelogs -i ChangeLog
+ dh_installdocs -i
+ dh_install -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch: build install
+ dh_testdir -a
+ dh_testroot -a
+ dh_installchangelogs -a ChangeLog
+ dh_installdocs -a
+ dh_install -a
+ dh_desktop -a
+ dh_installmenu -a
+ dh_strip -a --dbg-package=tmw-dbg
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure