summaryrefslogtreecommitdiff
path: root/libs/enet/CMakeLists.txt
diff options
context:
space:
mode:
authorDarkWind <darkwindmsn@hotmail.com>2011-02-15 20:05:02 +0100
committerBernd Wachter <bwachter-tmw@lart.info>2011-02-15 21:16:50 +0200
commit3c93bde383fad59972ae3004471b2bb567438b9d (patch)
tree743cca5bcf5a4e2b12ecccf544c0ca5ff6dcd0ae /libs/enet/CMakeLists.txt
parent377d5160cbaa40a4a8e83dd35d74bec6aeb208e0 (diff)
downloadmana-client-3c93bde383fad59972ae3004471b2bb567438b9d.tar.gz
mana-client-3c93bde383fad59972ae3004471b2bb567438b9d.tar.bz2
mana-client-3c93bde383fad59972ae3004471b2bb567438b9d.tar.xz
mana-client-3c93bde383fad59972ae3004471b2bb567438b9d.zip
Fix compilation on Haiku and set config and data paths for it.
Diffstat (limited to 'libs/enet/CMakeLists.txt')
-rw-r--r--libs/enet/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/enet/CMakeLists.txt b/libs/enet/CMakeLists.txt
index 714d9c03..52895918 100644
--- a/libs/enet/CMakeLists.txt
+++ b/libs/enet/CMakeLists.txt
@@ -52,4 +52,7 @@ SET (SRCS
INCLUDE_DIRECTORIES("include")
ADD_LIBRARY(enet STATIC ${SRCS})
-SET_TARGET_PROPERTIES(enet PROPERTIES COMPILE_FLAGS "${FLAGS}") \ No newline at end of file
+IF (BEOS)
+ TARGET_LINK_LIBRARIES(enet network)
+ENDIF()
+SET_TARGET_PROPERTIES(enet PROPERTIES COMPILE_FLAGS "${FLAGS}")