summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorYohann Ferreira <bertram@cegetel.net>2005-05-05 17:15:17 +0000
committerYohann Ferreira <bertram@cegetel.net>2005-05-05 17:15:17 +0000
commit674153d6146a97db5279ca358a802d5abf252432 (patch)
treefd1a799e0f318d25213e83a5eeca7de676f40c74 /debian/rules
parente40c16a5f31cab575b1efb4dc69f679e2e857856 (diff)
downloadmana-client-674153d6146a97db5279ca358a802d5abf252432.tar.gz
mana-client-674153d6146a97db5279ca358a802d5abf252432.tar.bz2
mana-client-674153d6146a97db5279ca358a802d5abf252432.tar.xz
mana-client-674153d6146a97db5279ca358a802d5abf252432.zip
Debian Tweaks
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 9 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 4efd5061..ab98c856 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,8 @@ endif
config.status: configure
dh_testdir
- CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
+ ./autogen.sh
+ CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man6/man --infodir=/usr/share/doc/tmw --datadir=/usr/share/games --bindir=/usr/games
build: build-stamp
@@ -61,12 +62,15 @@ install: build
dh_clean -k
dh_installdirs
- dh_install
-
-
# Build architecture-independent files here.
binary-indep: build install
-# We have nothing to do by default.
+ DESTDIR=$(CURDIR)/debian/tmp/ \
+ $(MAKE) install datadir=/usr/share/games bindir=/usr/games \
+ desktopdir=/usr/share/applications
+
+ cp data/icons/tmw-icon.xpm debian/tmp/usr/share/pixmaps/tmw.xpm
+ mv data/icons/tmw-icon.png debian/tmp/usr/share/pixmaps/tmw.png
+
# Build architecture-dependent files here.
binary-arch: build install