summaryrefslogtreecommitdiff
path: root/data/graphics/CMakeLists.txt
diff options
context:
space:
mode:
authorJared Adams <jaxad0127@gmail.com>2010-05-09 14:31:43 -0600
committerJared Adams <jaxad0127@gmail.com>2010-05-09 15:09:56 -0600
commitf269d5a68e6a22676c49961c7529b9c00dc90649 (patch)
tree3ccce636203883c0009146099df9d4854cab2171 /data/graphics/CMakeLists.txt
parent9baedc27191c82bbf1fedee2a7e738bc5b267c0e (diff)
downloadmana-client-f269d5a68e6a22676c49961c7529b9c00dc90649.tar.gz
mana-client-f269d5a68e6a22676c49961c7529b9c00dc90649.tar.bz2
mana-client-f269d5a68e6a22676c49961c7529b9c00dc90649.tar.xz
mana-client-f269d5a68e6a22676c49961c7529b9c00dc90649.zip
Move target cursor management into ActorSprite
This simplifies handling of target cursors, centralizing their logic into a single class, instead of two. Also make them more flexible and move the image files outside of the theme so servers can can control them and give them better names. Reviewed-by: Thorbjørn Lindeijer
Diffstat (limited to 'data/graphics/CMakeLists.txt')
-rw-r--r--data/graphics/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/data/graphics/CMakeLists.txt b/data/graphics/CMakeLists.txt
index 58d75523..d7e78c30 100644
--- a/data/graphics/CMakeLists.txt
+++ b/data/graphics/CMakeLists.txt
@@ -1,2 +1,11 @@
ADD_SUBDIRECTORY(gui)
ADD_SUBDIRECTORY(images)
+
+SET (FILES
+ target-cursor-in-range-l.png
+ target-cursor-in-range-m.png
+ target-cursor-in-range-s.png
+ target-cursor-normal-l.png
+ target-cursor-normal-m.png
+ target-cursor-normal-s.png
+ ) \ No newline at end of file