summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMateusz Kaduk <mateusz.kaduk@gmail.com>2005-01-17 18:57:38 +0000
committerMateusz Kaduk <mateusz.kaduk@gmail.com>2005-01-17 18:57:38 +0000
commit76ce363a43cc6d06de133d167b153056f25cdbdf (patch)
tree105e180537e6e2887485595f61f37110f9fa920e /configure.in
parent694e6e4148e19168f930406b13a3f63981341c05 (diff)
downloadmana-client-76ce363a43cc6d06de133d167b153056f25cdbdf.tar.gz
mana-client-76ce363a43cc6d06de133d167b153056f25cdbdf.tar.bz2
mana-client-76ce363a43cc6d06de133d167b153056f25cdbdf.tar.xz
mana-client-76ce363a43cc6d06de133d167b153056f25cdbdf.zip
Removed allegro from autoconf and added -lguichan_sdl
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in28
1 files changed, 1 insertions, 27 deletions
diff --git a/configure.in b/configure.in
index 84f917fc..ce7a99e0 100755
--- a/configure.in
+++ b/configure.in
@@ -76,7 +76,7 @@ FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/loca
])
if test -n "$LIBSDL_CONFIG"; then
- LIBSDL_LIBS="`$LIBSDL_CONFIG --libs`"
+ LIBSDL_LIBS="`$LIBSDL_CONFIG --libs` -lSDL_image -lSDL_mixer"
LIBSDL_RPATH=
for args in $LIBSDL_LIBS; do
case $args in
@@ -93,34 +93,8 @@ else
AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 0, [Defines if your system has the LIBSDL library])
fi
-FIND_PATH(allegro-config, LIBALLEGRO_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
- AC_MSG_ERROR([Could not find Allegro anywhere, check http://www.talula.demon.co.uk/allegro])
-])
-
-if test -n "$LIBALLEGRO_CONFIG"; then
- LIBALLEGRO_LIBS="`$LIBALLEGRO_CONFIG --libs` -lguichan_allegro -lguichan"
- LIBALLEGRO_RPATH=
- for args in $LIBALLEGRO_LIBS; do
- case $args in
- -L*)
- LIBALLEGRO_RPATH="$LIBALLEGRO_RPATH $args"
- ;;
- esac
- done
- LIBALLEGRO_RPATH=`echo $LIBALLEGRO_RPATH | sed -e "s/-L/-R/g"`
- LIBALLEGRO_CFLAGS="`$LIBALLEGRO_CONFIG --cflags`"
-
- AC_DEFINE_UNQUOTED(HAVE_LIBALLEGRO, 1, [Defines if your system has the LIBALLEGRO library])
-else
- AC_DEFINE_UNQUOTED(HAVE_LIBALLEGRO, 0, [Defines if your system has the LIBALLEGRO library])
-fi
-
AC_SUBST(LIBSDL_LIBS)
AC_SUBST(LIBSDL_CFLAGS)
AC_SUBST(LIBSDL_RPATH)
-AC_SUBST(LIBALLEGRO_LIBS)
-AC_SUBST(LIBALLEGRO_CFLAGS)
-AC_SUBST(LIBALLEGRO_RPATH)
-
AC_OUTPUT(Makefile src/Makefile)