summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMateusz Kaduk <mateusz.kaduk@gmail.com>2005-01-17 22:20:49 +0000
committerMateusz Kaduk <mateusz.kaduk@gmail.com>2005-01-17 22:20:49 +0000
commit94808d9f6c958106176f891b35cb7d59f63c56c7 (patch)
tree579bd3975a50682be9fa5852e648e216e249bb1a /configure.in
parent5b2fde1c744c9cc5d1a62c5177b8fb23dfee8378 (diff)
downloadmana-client-94808d9f6c958106176f891b35cb7d59f63c56c7.tar.gz
mana-client-94808d9f6c958106176f891b35cb7d59f63c56c7.tar.bz2
mana-client-94808d9f6c958106176f891b35cb7d59f63c56c7.tar.xz
mana-client-94808d9f6c958106176f891b35cb7d59f63c56c7.zip
Checking for SDL_mixer and SDL_image in configure
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ce7a99e0..c28be9bb 100755
--- a/configure.in
+++ b/configure.in
@@ -71,6 +71,14 @@ AC_DEFUN(FIND_PATH,
fi
])
+# Check for SDL_image and SDL_mixer library
+AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
+AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
+(http://www.libsdl.org/projects/SDL_image/)]))
+AC_CHECK_LIB(SDL_mixer, Mix_OpenAudio, ,
+AC_MSG_ERROR([ *** Unable to find SDL_mixer library
+(http://www.libsdl.org/projects/SDL_mixer/)]))
+
FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
AC_MSG_ERROR([Could not find libsdl anywhere, check http://www.sdl.org])
])