summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-02-25 22:28:13 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-02-25 23:18:35 +0100
commitd1f7e4f5090ac61142415edaa51f2af86aecc188 (patch)
tree710c96208bd4ada7f6e19ea6200048b4438c61a2 /configure.ac
parent861b28494e8c0f8701c093f82f152c3bcdbae9fd (diff)
downloadmana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.tar.gz
mana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.tar.bz2
mana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.tar.xz
mana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.zip
Added paste facility from the Wormux project
With CMakeLists.txt adaptions from the Aethyra project. Reviewed-by: Bernd Wachter Reviewed-by: Jared Adams
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 739b1cb1..54b510d3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,24 @@ AC_CHECK_LIB(SDL_gfx, rotozoomSurfaceXY, ,
AC_MSG_ERROR([ *** Unable to find SDL_gfx library (http://www.ferzkopp.net/joomla/software-mainmenu-14/4-ferzkopps-linux-software/19-sdlgfx)]))
AC_CHECK_HEADERS(SDL_rotozoom.h, ,)
+# === Check for X11 (check borrowed from Wormux) ========================
+# Deactivated on purpose under OSX (in case X11 SDK is installed)
+if test "x$OSX" != "xyes" ; then
+ AC_CHECK_HEADER(X11/Xlib.h, check_x11="yes",check_x11="no")
+ if test x${check_x11} = xno ; then
+ AC_CHECK_HEADER(X11R6/Xlib.h,
+ [ check_x11="yes"
+ LDFLAGS="-L/usr/X11R6/include $CFLAGS"],
+ check_x11="no")
+ fi
+ if test x${check_x11} = xyes ; then
+ AC_CHECK_LIB(X11, XOpenDisplay,
+ [ LIBS="$LIBS -lX11"
+ AC_DEFINE(USE_X11, 1, [Define to use X11 copy'n'paste]) ],
+ [])
+ fi
+fi
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])