summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Bradshaw <daniel+commits@the-cell.co.uk>2010-01-31 13:14:07 +0000
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-01-31 17:50:29 +0100
commit2ff6ad2e8a67bd8ef34b56b866ef277c30135f19 (patch)
tree536497f63044441a6e8032209446d1c3213b9d55 /configure.ac
parent22c75a346e029fad746b6aa0b123c886ddeb5c75 (diff)
downloadmana-client-2ff6ad2e8a67bd8ef34b56b866ef277c30135f19.tar.gz
mana-client-2ff6ad2e8a67bd8ef34b56b866ef277c30135f19.tar.bz2
mana-client-2ff6ad2e8a67bd8ef34b56b866ef277c30135f19.tar.xz
mana-client-2ff6ad2e8a67bd8ef34b56b866ef277c30135f19.zip
Unify eAthena and manaserv support in to one build.
Finish support for server types in the server dialog. Using the new server type function, strip out ifdefs, replacing them with if blocks for later merging in smaller atomic commits. Remove any remaining references to the support defs, including in build system.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac38
1 files changed, 4 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 9622d8aa..b102e1e8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -103,39 +103,10 @@ else
AC_DEFINE(USE_OPENGL, 1, [Defines if Mana should have OpenGL support])
fi
-# Enable either Manaserv or eAthena
-AC_ARG_WITH(
- [server],
- AS_HELP_STRING(
- [--with-server=ARG],
- [which server to use [[ARG=manaserv,eathena]]
- [(default=manaserv)]]
- ),
- [if test "$withval" = "yes"; then
- # default is manaserv
- with_server="manaserv"
- elif test "$withval" = "no"; then
- AC_MSG_ERROR([$PACKAGE_NAME cannot run without a server.])
- else
- with_server="$withval"
- fi],
- [with_server="manaserv"]
-)
-
-if test "$with_server" = "manaserv"; then
- AC_CHECK_LIB([enet], [enet_initialize], ,
- AC_MSG_ERROR([ *** Unable to find enet library (http://enet.bespin.org/)]))
- AC_DEFINE(MANASERV_SUPPORT, 1, [Defines if manaserv support is enabled])
-elif test "$with_server" = "eathena"; then
- AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
- AC_MSG_ERROR([ *** Unable to find SDL_net library]))
- AC_DEFINE(EATHENA_SUPPORT, 1, [Defines if eAthena support is enabled])
-else
- AC_MSG_ERROR([unknown server: $with_server])
-fi
-
-AM_CONDITIONAL(SERVER_MANASERV, test "$with_server" = "manaserv")
-AM_CONDITIONAL(SERVER_EATHENA, test "$with_server" = "eathena")
+AC_CHECK_LIB([enet], [enet_initialize], ,
+AC_MSG_ERROR([ *** Unable to find enet library (http://enet.bespin.org/)]))
+AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
+AC_MSG_ERROR([ *** Unable to find SDL_net library]))
AC_CONFIG_FILES([
Makefile
@@ -155,7 +126,6 @@ AC_OUTPUT
echo
echo "Build with OpenGL: $with_opengl"
-echo "Supported server: $with_server"
echo
echo "configure complete, now type \"make\""
echo