summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-12 10:58:01 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-12 10:58:01 +0000
commit3638ed852b95ca8ced3b0962df00c6bf08c7201b (patch)
tree5b9e65426dafd91c1a762fbb5297b8f1e959503b /configure.ac
parente54118f8d2c74e8642c17721a33df2fd5d287989 (diff)
downloadmana-client-3638ed852b95ca8ced3b0962df00c6bf08c7201b.tar.gz
mana-client-3638ed852b95ca8ced3b0962df00c6bf08c7201b.tar.bz2
mana-client-3638ed852b95ca8ced3b0962df00c6bf08c7201b.tar.xz
mana-client-3638ed852b95ca8ced3b0962df00c6bf08c7201b.zip
Added modules and moved some files around.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index df03a3a9..d80598cb 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT(The Mana World, 0.0.9, umperio@users.sourceforge.net)
+AC_INIT([The Mana World], [0.0.9], [umperio@users.sourceforge.net])
AC_CONFIG_SRCDIR([config.h.in])
AC_CONFIG_HEADER([config.h])
AC_LANG_CPLUSPLUS
@@ -14,6 +14,14 @@ AC_PROG_MAKE_SET
#AC_CHECK_LIB([guichan], [_ZN3gcn7TextBox6addRowESs])
#AC_CHECK_LIB([guichan_sdl], [_ZN3gcn8SDLInput17dequeueMouseInputEv])
+# Check for SDL_image and SDL_mixer library
+AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
+AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
+(http://www.libsdl.org/projects/SDL_image/)]))
+AC_CHECK_LIB(SDL_mixer, Mix_OpenAudio, ,
+AC_MSG_ERROR([ *** Unable to find SDL_mixer library
+(http://www.libsdl.org/projects/SDL_mixer/)]))
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
@@ -90,14 +98,6 @@ AC_DEFUN(FIND_PATH,
fi
])
-# Check for SDL_image and SDL_mixer library
-AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
-AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
-(http://www.libsdl.org/projects/SDL_image/)]))
-AC_CHECK_LIB(SDL_mixer, Mix_OpenAudio, ,
-AC_MSG_ERROR([ *** Unable to find SDL_mixer library
-(http://www.libsdl.org/projects/SDL_mixer/)]))
-
FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
AC_MSG_ERROR([Could not find libsdl anywhere, check http://www.sdl.org])
])