summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYohann Ferreira <yohann_dot_ferreira_at_orange_dot_efer>2010-12-06 20:37:13 +0100
committerYohann Ferreira <yohann_dot_ferreira_at_orange_dot_efer>2010-12-06 20:37:13 +0100
commit48241af5432ee8248151c41bdc5321ba508f1d11 (patch)
tree5e06ec943114e4c2d512b8e91792ce74d0a194bf /configure.ac
parent3f55464f83203e8ddafa77af9290a7c0d4fb1d2a (diff)
downloadmana-client-48241af5432ee8248151c41bdc5321ba508f1d11.tar.gz
mana-client-48241af5432ee8248151c41bdc5321ba508f1d11.tar.bz2
mana-client-48241af5432ee8248151c41bdc5321ba508f1d11.tar.xz
mana-client-48241af5432ee8248151c41bdc5321ba508f1d11.zip
Removed deprecated autotools support.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac154
1 files changed, 0 insertions, 154 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100755
index 64097586..00000000
--- a/configure.ac
+++ /dev/null
@@ -1,154 +0,0 @@
-AC_PREREQ(2.59)
-AC_INIT([Mana], [1.0.0-beta2], [dev@manasource.org], [mana])
-AM_INIT_AUTOMAKE([1.9])
-AC_CONFIG_HEADERS([config.h:config.h.in])
-AC_LANG_CPLUSPLUS
-
-# Checks for programs.
-AC_PROG_CXX
-AC_PROG_INSTALL
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_TIME
-
-# Checks for library functions.
-AC_FUNC_ERROR_AT_LINE
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
-AC_FUNC_SELECT_ARGTYPES
-AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([atexit floor getcwd gethostbyname memset mkdir select socket])
-
-# Checks for internationalization support
-AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION([0.16.1])
-
-# Search for *-config
-AC_PATH_PROG(SDL_CONFIG, sdl-config)
-AC_PATH_PROG(PKG_CONFIG, pkg-config)
-AC_PATH_PROG(CURL_CONFIG, curl-config)
-
-# Checks for libraries
-AC_CHECK_LIB([pthread], [pthread_create], ,
-AC_MSG_ERROR([ *** Unable to find pthread library]))
-
-AC_CHECK_LIB([guichan], [gcnGuichanVersion], ,
-AC_MSG_ERROR([ *** Unable to find Guichan library (http://guichan.sf.net/)]))
-AC_CHECK_HEADERS([guichan.hpp], ,
-AC_MSG_ERROR([ *** Guichan library found but cannot find headers (http://guichan.sf.net/)]))
-
-if test -n "$SDL_CONFIG"; then
- LIBS="$LIBS `$SDL_CONFIG --libs`"
- CPPFLAGS="$CPPFLAGS `$SDL_CONFIG --cflags`"
-fi
-AC_CHECK_LIB([SDL], [SDL_Init], ,
-AC_MSG_ERROR([ *** Unable to find SDL library (http://www.libsdl.org/)]))
-AC_CHECK_HEADERS([SDL.h], ,
-AC_MSG_ERROR([ *** SDL library found but cannot find headers (http://www.libsdl.org/)]))
-
-AC_CHECK_LIB([z], [inflate], ,
-AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
-
-AC_CHECK_LIB([physfs], [PHYSFS_init], ,
-AC_MSG_ERROR([ *** Unable to find PhysFS library (http://icculus.org/physfs/)]))
-AC_CHECK_HEADERS([physfs.h], ,
-AC_MSG_ERROR([ *** PhysFS library found but cannot find headers (http://icculus.org/physfs/)]))
-
-if test -n "$CURL_CONFIG"; then
- LIBS="$LIBS `$CURL_CONFIG --libs`"
- CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
-fi
-AC_CHECK_LIB([curl], [curl_global_init], ,
-AC_MSG_ERROR([ *** Unable to find CURL library (http://curl.haxx.se/)]))
-AC_CHECK_HEADERS([curl/curl.h], ,
-AC_MSG_ERROR([ *** CURL library found but cannot find headers (http://curl.haxx.se/)]))
-
-if test -n "$PKG_CONFIG"; then
- LIBS="$LIBS `$PKG_CONFIG --libs libxml-2.0`"
- CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags libxml-2.0`"
-fi
-AC_CHECK_LIB([xml2], [xmlInitParser], ,
-AC_MSG_ERROR([ *** Unable to find libxml2 library (http://xmlsoft.org/)]))
-AC_CHECK_HEADERS([libxml/xmlreader.h], ,
-AC_MSG_ERROR([ *** libxml2 library found but cannot find headers (http://xmlsoft.org/)]))
-
-AC_CHECK_LIB(png, png_write_info, ,
-AC_MSG_ERROR([ *** Unable to find png library]))
-
-AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
-AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
-(http://www.libsdl.org/projects/SDL_image/)]))
-
-AC_CHECK_LIB(SDL_ttf, TTF_Quit, ,
-AC_MSG_ERROR([ *** Unable to find SDL_ttf library (http://www.libsdl.org/projects/SDL_ttf/)]))
-
-AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio], ,
-AC_MSG_ERROR([ *** Unable to find SDL_mixer library (http://www.libsdl.org/projects/SDL_mixer/)]))
-
-AC_CHECK_LIB([guichan_sdl], [gcnSDL], ,
-AC_MSG_ERROR([ *** Unable to find Guichan SDL library (http://guichan.sf.net/)]))
-
-AC_CHECK_LIB(SDL_gfx, rotozoomSurfaceXY, ,
-AC_MSG_ERROR([ *** Unable to find SDL_gfx library (http://www.ferzkopp.net/joomla/software-mainmenu-14/4-ferzkopps-linux-software/19-sdlgfx)]))
-AC_CHECK_HEADERS(SDL_rotozoom.h, ,)
-
-# === Check for X11 (check borrowed from Wormux) ========================
-# Deactivated on purpose under OSX (in case X11 SDK is installed)
-if test "x$OSX" != "xyes" ; then
- AC_CHECK_HEADER(X11/Xlib.h, check_x11="yes",check_x11="no")
- if test x${check_x11} = xno ; then
- AC_CHECK_HEADER(X11R6/Xlib.h,
- [ check_x11="yes"
- LDFLAGS="-L/usr/X11R6/include $CFLAGS"],
- check_x11="no")
- fi
- if test x${check_x11} = xyes ; then
- AC_CHECK_LIB(X11, XOpenDisplay,
- [ LIBS="$LIBS -lX11"
- AC_DEFINE(USE_X11, 1, [Define to use X11 copy'n'paste]) ],
- [])
- fi
-fi
-
-# Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
-
-# Option to enable OpenGL
-AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
-if test "x$with_opengl" == "xno"; then
- with_opengl=no
-else
- with_opengl=yes
- AC_CHECK_LIB([GL], [glBegin], ,
- AC_MSG_ERROR([ *** Unable to find OpenGL library]))
- AC_DEFINE(USE_OPENGL, 1, [Defines if Mana should have OpenGL support])
-fi
-
-AC_CHECK_LIB([enet], [enet_initialize], ,
-AC_MSG_ERROR([ *** Unable to find enet library (http://enet.bespin.org/)]))
-AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
-AC_MSG_ERROR([ *** Unable to find SDL_net library]))
-
-AC_CONFIG_FILES([
-Makefile
-src/Makefile
-data/Makefile
-data/fonts/Makefile
-data/graphics/Makefile
-data/graphics/gui/Makefile
-data/graphics/images/Makefile
-data/graphics/sprites/Makefile
-data/help/Makefile
-data/icons/Makefile
-docs/Makefile
-po/Makefile.in
-])
-
-AC_OUTPUT
-
-echo
-echo "Build with OpenGL: $with_opengl"
-echo
-echo "configure complete, now type \"make\""
-echo