summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2006-08-02 12:41:35 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2009-01-05 21:36:33 +0100
commitce0d7b62824d620ec8c3daceac5710fbbd6b12f1 (patch)
tree91e86ed20d398962dee82b75dc10dba5f0f9f233 /configure.ac
parent090b4893a57a1b7e9c83f7db043843d35016fcff (diff)
downloadmana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.tar.gz
mana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.tar.bz2
mana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.tar.xz
mana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.zip
Cleaned autotools files
Put object files in subdirectories. Moved compilation flags to configure script. Added library header checks. (cherry picked from mainline commit 0bebbc320d50178a7ece573319cd6687a950dafa)
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac68
1 files changed, 36 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 791a84c5..c95d3006 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
AC_PREREQ(2.59)
AC_INIT([The Mana World], [0.0.27], [themanaworld-devel@lists.sourceforge.net], [tmw])
+AM_INIT_AUTOMAKE
AC_CONFIG_HEADERS([config.h:config.h.in])
AC_LANG_CPLUSPLUS
@@ -22,31 +23,54 @@ AC_FUNC_SELECT_ARGTYPES
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([atexit floor getcwd gethostbyname memset mkdir select socket])
+# Search for *-config
+AC_PATH_PROG(SDL_CONFIG, sdl-config)
+AC_PATH_PROG(PKG_CONFIG, pkg-config)
+AC_PATH_PROG(CURL_CONFIG, curl-config)
+
# Checks for libraries
AC_CHECK_LIB([pthread], [pthread_create], ,
AC_MSG_ERROR([ *** Unable to find pthread library]))
AC_CHECK_LIB([guichan], [gcnGuichanVersion], ,
-AC_MSG_ERROR([ *** Unable to find Guichan library (guichan.sf.net)]))
+AC_MSG_ERROR([ *** Unable to find Guichan library (http://guichan.sf.net/)]))
+AC_CHECK_HEADERS([guichan.hpp], ,
+AC_MSG_ERROR([ *** Guichan library found but cannot find headers (http://guichan.sf.net/)]))
-#AC_CHECK_LIB([guichan_sdl], [gcnSDL], ,
-#AC_MSG_ERROR([ *** Unable to find Guichan SDL library (guichan.sf.net)]))
+if test -n "$SDL_CONFIG"; then
+ LIBS="$LIBS `$SDL_CONFIG --libs`"
+ CPPFLAGS="$CPPFLAGS `$SDL_CONFIG --cflags`"
+fi
+AC_CHECK_LIB([SDL], [SDL_Init], ,
+AC_MSG_ERROR([ *** Unable to find SDL library (http://www.libsdl.org/)]))
+AC_CHECK_HEADERS([SDL.h], ,
+AC_MSG_ERROR([ *** SDL library found but cannot find headers (http://www.libsdl.org/)]))
AC_CHECK_LIB([z], [inflate], ,
AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
AC_CHECK_LIB([physfs], [PHYSFS_init], ,
-AC_MSG_ERROR([ *** Unable to find PhysFS library (icculus.org/physfs/)]))
+AC_MSG_ERROR([ *** Unable to find PhysFS library (http://icculus.org/physfs/)]))
+AC_CHECK_HEADERS([physfs.h], ,
+AC_MSG_ERROR([ *** PhysFS library found but cannot find headers (http://icculus.org/physfs/)]))
+if test -n "$CURL_CONFIG"; then
+ LIBS="$LIBS `$CURL_CONFIG --libs`"
+ CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
+fi
AC_CHECK_LIB([curl], [curl_global_init], ,
AC_MSG_ERROR([ *** Unable to find CURL library (http://curl.haxx.se/)]))
-CURL_LIBS=" `curl-config --libs`"
-CURL_CFLAGS=" `curl-config --cflags` "
-AC_SUBST(CURL_LIBS)
-AC_SUBST(CURL_CFLAGS)
+AC_CHECK_HEADERS([curl/curl.h], ,
+AC_MSG_ERROR([ *** CURL library found but cannot find headers (http://curl.haxx.se/)]))
+if test -n "$PKG_CONFIG"; then
+ LIBS="$LIBS `$PKG_CONFIG --libs libxml-2.0`"
+ CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags libxml-2.0`"
+fi
AC_CHECK_LIB([xml2], [xmlInitParser], ,
-AC_MSG_ERROR([ *** Unable to find libxml2 library (xmlsoft.org)]))
+AC_MSG_ERROR([ *** Unable to find libxml2 library (http://xmlsoft.org/)]))
+AC_CHECK_HEADERS([libxml/xmlreader.h], ,
+AC_MSG_ERROR([ *** libxml2 library found but cannot find headers (http://xmlsoft.org/)]))
AC_CHECK_LIB(png, png_write_info, ,
AC_MSG_ERROR([ *** Unable to find png library]))
@@ -61,6 +85,9 @@ AC_MSG_ERROR([ *** Unable to find SDL_ttf library (http://www.libsdl.org/project
AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio], ,
AC_MSG_ERROR([ *** Unable to find SDL_mixer library (http://www.libsdl.org/projects/SDL_mixer/)]))
+AC_CHECK_LIB([guichan_sdl], [gcnSDL], ,
+AC_MSG_ERROR([ *** Unable to find Guichan SDL library (http://guichan.sf.net/)]))
+
AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
AC_MSG_ERROR([ *** Unable to find SDL_net library]))
@@ -68,12 +95,6 @@ AC_MSG_ERROR([ *** Unable to find SDL_net library]))
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
-# Check for guichan headers
-AC_CHECK_HEADERS([guichan.hpp], ,
-AC_MSG_ERROR([*** Library found but cannot find headers (guichan.sf.net) *** ]))
-
-AM_INIT_AUTOMAKE
-
# Option to enable OpenGL
AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
if test "x$with_opengl" == "xno"; then
@@ -85,23 +106,6 @@ else
AC_DEFINE(USE_OPENGL, 1, [Defines if tmw should use an OpenGL display])
fi
-# Search for sdl-config
-AC_PATH_PROG(LIBSDL_CONFIG, sdl-config)
-
-if test -n "$LIBSDL_CONFIG"; then
- LIBSDL_LIBS="`$LIBSDL_CONFIG --libs` -lSDL_image -lSDL_mixer"
- LIBSDL_CFLAGS="`$LIBSDL_CONFIG --cflags`"
- AC_SUBST(LIBSDL_LIBS)
- AC_SUBST(LIBSDL_CFLAGS)
-
- AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 1,
- [Defines if your system has the LIBSDL library])
-else
- AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 0,
- [Defines if your system has the LIBSDL library])
- AC_MSG_ERROR([Could not find sdl-config, check http://www.libsdl.org])
-fi
-
AC_CONFIG_FILES([
Makefile
src/Makefile