summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2006-08-01 20:31:11 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2006-08-01 20:31:11 +0000
commitc2cde930ed189d70846bf86acfddf6fdd0c998f9 (patch)
tree01e97dbcafa4462c5bf16c7a833743c16260cc86 /configure.ac
parent0c9ddb1925420231b30dcb6a29b50e6586c36755 (diff)
downloadmana-client-c2cde930ed189d70846bf86acfddf6fdd0c998f9.tar.gz
mana-client-c2cde930ed189d70846bf86acfddf6fdd0c998f9.tar.bz2
mana-client-c2cde930ed189d70846bf86acfddf6fdd0c998f9.tar.xz
mana-client-c2cde930ed189d70846bf86acfddf6fdd0c998f9.zip
Moved some basic checks above the checks on the libraries we depend on, in
order to get rid of the confusing rpl_realloc error.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index ce30607f..d8f980d3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,20 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_HEADER_TIME
+AC_C_VOLATILE
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_FUNC_SELECT_ARGTYPES
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([atexit floor getcwd gethostbyname memset mkdir select socket])
+
# Checks for libraries
AC_CHECK_LIB([pthread], [pthread_create], ,
AC_MSG_ERROR([ *** Unable to find pthread library ]))
@@ -57,20 +71,6 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h str
AC_CHECK_HEADERS([guichan.hpp], ,
AC_MSG_ERROR([*** Library found but cannot find headers (guichan.sf.net) *** ]))
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_CONST
-AC_HEADER_TIME
-AC_C_VOLATILE
-
-# Checks for library functions.
-AC_FUNC_ERROR_AT_LINE
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
-AC_FUNC_SELECT_ARGTYPES
-AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([atexit floor getcwd gethostbyname memset mkdir select socket])
-
AM_INIT_AUTOMAKE
# Option to enable OpenGL