summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYohann Ferreira <yohann_dot_ferreira_at_orange_dot_fr>2010-05-27 18:37:04 +0200
committerYohann Ferreira <yohann_dot_ferreira_at_orange_dot_fr>2010-05-27 18:47:36 +0200
commit5b08d350f10b7ba1be2b966af68017b64d4bbcd0 (patch)
treee2eaf199d779a981ddbc867ce0c426c6e8f44e79 /configure.ac
parent98820e79e786f3d318a45e0f8e6100841530ff50 (diff)
downloadmana-client-5b08d350f10b7ba1be2b966af68017b64d4bbcd0.tar.gz
mana-client-5b08d350f10b7ba1be2b966af68017b64d4bbcd0.tar.bz2
mana-client-5b08d350f10b7ba1be2b966af68017b64d4bbcd0.tar.xz
mana-client-5b08d350f10b7ba1be2b966af68017b64d4bbcd0.zip
Added pseudo-check for the Guichan minimal required version: 0.8.0.
The guichan/widgetlistener.hpp file presence is now checked for both autotools and cmake. This resolves TMW-Mantis: #503 Reviewed-by: Jaxad0127
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d1f375f6..b1ceceec 100755
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,9 @@ AC_MSG_ERROR([ *** Unable to find Guichan library (http://guichan.sf.net/)]))
AC_CHECK_HEADERS([guichan.hpp], ,
AC_MSG_ERROR([ *** Guichan library found but cannot find headers (http://guichan.sf.net/)]))
+AC_CHECK_HEADERS([guichan/widgetlistener.hpp], ,
+AC_MSG_ERROR([ *** Guichan library version is found but version is < 0.8.0 (http://guichan.sf.net/)]))
+
if test -n "$SDL_CONFIG"; then
LIBS="$LIBS `$SDL_CONFIG --libs`"
CPPFLAGS="$CPPFLAGS `$SDL_CONFIG --cflags`"