summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDuane Bailey <nayryeliab@gmail.com>2005-09-17 21:35:26 +0000
committerDuane Bailey <nayryeliab@gmail.com>2005-09-17 21:35:26 +0000
commit3debd1554b39a6a2e790526fa02d56d1b81fda85 (patch)
tree360aed13b07b78d6260786cf28706b637037abdd /configure.ac
parent7eaa123ee5129ccd81ff169ada7665a812dee435 (diff)
downloadmana-client-3debd1554b39a6a2e790526fa02d56d1b81fda85.tar.gz
mana-client-3debd1554b39a6a2e790526fa02d56d1b81fda85.tar.bz2
mana-client-3debd1554b39a6a2e790526fa02d56d1b81fda85.tar.xz
mana-client-3debd1554b39a6a2e790526fa02d56d1b81fda85.zip
2005-09-17 Duane Bailey <nayryeliab@gmail.com>
* src/net/messagin.cpp, src/net/messageout.cpp, src/net/network.cpp: removed replaced MACOSX defines with big endian defines * src/graphics.cpp, src/graphics.h: added screenshot method * src/game.cpp: added code, so that when one presses 'alt-p' (for picture), it takes a screenshot and saves it to a png * src/Makefile.am, config.ac: added png library stuff
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c63e860..c4b98519 100755
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,9 @@ AC_MSG_ERROR([ *** Unable to find SDL_mixer library
AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
AC_MSG_ERROR([ *** Unable to find SDL_net library]))
+AC_CHECK_LIB(png, png_write_info, ,
+ACMSG_ERROR([ ** Unable to find png library]))
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])