summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2007-03-11 19:59:55 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2007-03-11 19:59:55 +0000
commitfc63e88f869919a8b035a5c41db8d05626526bde (patch)
tree8f1928d082ebbffc549c712a3f406c2141f43e01 /configure.ac
parent7b0f0ec315e66dcbdda58ada8b09a59bc5dcf6c9 (diff)
downloadmana-client-fc63e88f869919a8b035a5c41db8d05626526bde.tar.gz
mana-client-fc63e88f869919a8b035a5c41db8d05626526bde.tar.bz2
mana-client-fc63e88f869919a8b035a5c41db8d05626526bde.tar.xz
mana-client-fc63e88f869919a8b035a5c41db8d05626526bde.zip
Merged 0.0 changes from revision 3065 to 3177 to trunk.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ca31930e..21d9ef56 100755
--- a/configure.ac
+++ b/configure.ac
@@ -94,15 +94,15 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
# Option to enable OpenGL
-AC_ARG_WITH(opengl, AS_HELP_STRING([--with-opengl],[use OpenGL (default is no)]))
-if test "x$with_opengl" == "xyes"; then
+AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
+if test "x$with_opengl" == "xno"; then
+ with_opengl=no
+else
AC_CHECK_LIB([GL], [glBegin], ,
AC_MSG_ERROR([ *** Unable to find OpenGL library]))
AC_CHECK_LIB([guichan_opengl], [gcnOpenGL], ,
AC_MSG_ERROR([ *** Unable to find Guichan OpenGL library (guichan.sf.net)]))
AC_DEFINE(USE_OPENGL, 1, [Defines if tmw should use an OpenGL display])
-else
- with_opengl=no
fi
AC_CONFIG_FILES([
@@ -113,7 +113,6 @@ data/graphics/Makefile
data/graphics/gui/Makefile
data/graphics/images/Makefile
data/graphics/images/ambient/Makefile
-data/graphics/sprites/Makefile
data/graphics/tiles/Makefile
data/help/Makefile
data/icons/Makefile