summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBernd Wachter <bwachter-tmw@lart.info>2009-04-06 00:29:04 +0200
committerBjørn Lindeijer <bjorn@lindeijer.nl>2009-04-06 15:00:14 +0200
commite76f1fe00f03ae5977e94f830980034c2453d884 (patch)
tree9812ab1e2cb6e41956dd8b66fd77c11ab84cfc57 /CMakeLists.txt
parentee4f4fd0aff3a614b4e60ab082ff4b493c18da93 (diff)
downloadmana-client-e76f1fe00f03ae5977e94f830980034c2453d884.tar.gz
mana-client-e76f1fe00f03ae5977e94f830980034c2453d884.tar.bz2
mana-client-e76f1fe00f03ae5977e94f830980034c2453d884.tar.xz
mana-client-e76f1fe00f03ae5977e94f830980034c2453d884.zip
Fixed DATADIR and LOCALEDIR variables for CMake-build; fixed game data installation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf66c6ae..6cefa798 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,8 +12,10 @@ OPTION(WITH_OPENGL "Enable OpenGL support" ON)
IF (WIN32)
SET(PKG_DATADIR ".")
SET(PKG_BINDIR ".")
+ SET(LOCALEDIR ".")
ELSE (WIN32)
SET(PKG_DATADIR ${CMAKE_INSTALL_PREFIX}/share/tmw)
+ SET(LOCALEDIR ${CMAKE_INSTALL_PREFIX}/share/locale)
SET(PKG_BINDIR ${CMAKE_INSTALL_PREFIX}/bin)
ENDIF (WIN32)