summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Alves <simpledark+manasource@gmail.com>2010-07-22 22:42:54 +0200
committerBernd Wachter <bwachter-tmw@lart.info>2010-07-23 12:27:55 +0300
commit94067246b02a981e3e3b058120551beb8a830c7e (patch)
tree1c81a4bcc64429c260dbc1276f549414d831a25d /CMakeLists.txt
parent89765ba6256ee39bf034ae6fddf9adacca6dbdd1 (diff)
downloadmana-client-94067246b02a981e3e3b058120551beb8a830c7e.tar.gz
mana-client-94067246b02a981e3e3b058120551beb8a830c7e.tar.bz2
mana-client-94067246b02a981e3e3b058120551beb8a830c7e.tar.xz
mana-client-94067246b02a981e3e3b058120551beb8a830c7e.zip
Fixing compatibility with cmake 2.6.0
The syntax IF ((condition) OR (condition)) is not accepted by cmake prior to 2.6.4. The syntax IF (NOT (condition OR condition)) is also not accepted. The patch should address this without affecting newer versions. A newline character was also automatically added to the end of the file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15a55d91..b396b8e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ ENDIF()
STRING(REPLACE "." " " _VERSION ${VERSION})
SEPARATE_ARGUMENTS(_VERSION)
LIST(LENGTH _VERSION _LEN)
-IF(NOT (_LEN EQUAL 4 OR _LEN EQUAL 3))
+IF(NOT _LEN EQUAL 4 AND NOT _LEN EQUAL 3)
MESSAGE(FATAL_ERROR "Version needs to be in the form MAJOR.MINOR.RELEASE[.BUILD]")
ENDIF()
@@ -70,4 +70,4 @@ IF(WIN32)
SET(CPACK_PACKAGE_ICON "${CMAKE_CURRENT_SOURCE_DIR}/packaging/windows/setup_welcome.bmp")
SET(CPACK_NSIS_URL_INFO_ABOUT "http://www.manasource.org")
ENDIF()
-INCLUDE(CPack) \ No newline at end of file
+INCLUDE(CPack)