summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBernd Wachter <bwachter@lart.info>2010-01-26 09:46:17 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-01-26 09:51:36 +0100
commitceba94eb0bfc4c6595f550c7371ecea9aae940ec (patch)
tree494e88d469a5d0e049f64821e793d83cc4466a73 /CMakeLists.txt
parentb444a016ef504376c64beb03d4701bfe1b6417f7 (diff)
downloadmana-client-ceba94eb0bfc4c6595f550c7371ecea9aae940ec.tar.gz
mana-client-ceba94eb0bfc4c6595f550c7371ecea9aae940ec.tar.bz2
mana-client-ceba94eb0bfc4c6595f550c7371ecea9aae940ec.tar.xz
mana-client-ceba94eb0bfc4c6595f550c7371ecea9aae940ec.zip
Enclose -Wall option in g++ check, remove -g flag
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a7fc894..f98e9f61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,8 +11,10 @@ SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMake/Modules)
FIND_PACKAGE(Gettext)
-# Help getting compilation warnings
-set(CMAKE_CXX_FLAGS "-g -Wall")
+IF (CMAKE_COMPILER_IS_GNUCXX)
+ # Help getting compilation warnings
+ SET(CMAKE_CXX_FLAGS "-Wall")
+ENDIF()
OPTION(WITH_OPENGL "Enable OpenGL support" ON)
OPTION(ENABLE_NLS "Enable building of tranlations" ON)