summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11c58d0..a0587b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,12 @@ set(PACKAGEDATADIR "${CMAKE_INSTALL_FULL_DATAROOTDIR}/tmwa")
set(PACKAGELOCALSTATEDIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/tmwa")
set(PACKAGESYSCONFDIR "${CMAKE_INSTALL_FULL_SYSCONFDIR}/tmwa")
-configure_file(src/conf/install.hpp.in src/conf/install.hpp @ONLY)
-configure_file(src/conf/version.hpp.in src/conf/version.hpp @ONLY)
+# Generate the install.hpp and version.hpp files in the source directory.
+# TODO: Is there a nicer way to handle this so we're still able to make fully
+# out-of-tree builds, generating the files in the build directory, but still
+# having them found by includes?
+configure_file(src/conf/install.hpp.in ${CMAKE_SOURCE_DIR}/src/conf/install.hpp @ONLY)
+configure_file(src/conf/version.hpp.in ${CMAKE_SOURCE_DIR}/src/conf/version.hpp @ONLY)
set(conf_SOURCES ${conf_SOURCES} src/conf/install.hpp src/conf/version.hpp)
# Add a shared library: libtmwa-shared.so.0