summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt44
1 files changed, 22 insertions, 22 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 25d1e9be9..59d3416fb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -579,8 +579,8 @@ SET(SRCS
gui/windows/updaterwindow.h
gui/userpalette.cpp
gui/userpalette.h
- progs/manaplus/gui/viewport.cpp
- progs/manaplus/gui/viewport.h
+ progs/manaverse/gui/viewport.cpp
+ progs/manaverse/gui/viewport.h
gui/viewport.h
gui/windowmanager.cpp
gui/windowmanager.h
@@ -1052,23 +1052,23 @@ SET(SRCS
test/testmain.h
actions/actiondef.h
actions/actionfuncptr.h
- progs/manaplus/actions/actions.cpp
+ progs/manaverse/actions/actions.cpp
actions/actions.h
- progs/manaplus/actions/chat.cpp
+ progs/manaverse/actions/chat.cpp
actions/chat.h
- progs/manaplus/actions/commands.cpp
+ progs/manaverse/actions/commands.cpp
actions/commands.h
- progs/manaplus/actions/move.cpp
+ progs/manaverse/actions/move.cpp
actions/move.h
- progs/manaplus/actions/pets.cpp
+ progs/manaverse/actions/pets.cpp
actions/pets.h
- progs/manaplus/actions/statusbar.cpp
+ progs/manaverse/actions/statusbar.cpp
actions/statusbar.h
- progs/manaplus/actions/tabs.cpp
+ progs/manaverse/actions/tabs.cpp
actions/tabs.h
- progs/manaplus/actions/target.cpp
+ progs/manaverse/actions/target.cpp
actions/target.h
- progs/manaplus/actions/windows.cpp
+ progs/manaverse/actions/windows.cpp
actions/windows.h
being/actor.cpp
being/actor.h
@@ -1120,8 +1120,8 @@ SET(SRCS
spellmanager.h
chatlogger.cpp
chatlogger.h
- progs/manaplus/client.cpp
- progs/manaplus/client.h
+ progs/manaverse/client.cpp
+ progs/manaverse/client.h
client.h
commandline.cpp
commandline.h
@@ -2215,18 +2215,18 @@ IF (WIN32)
${SRCS}
fs/specialfolder.cpp
fs/specialfolder.h
- manaplus.rc
+ manaverse.rc
)
SET(DYE_CMD_SRCS
${DYE_CMD_SRCS}
fs/specialfolder.cpp
fs/specialfolder.h
- manaplus.rc
+ manaverse.rc
)
ENDIF ()
-#SET (PROGRAMS manaplus dyecmd)
-SET (PROGRAMS manaplus)
+#SET (PROGRAMS manaverse dyecmd)
+SET (PROGRAMS manaverse)
IF (ENABLE_TMWA)
SET(SRCS ${SRCS} ${SRCS_TMWA})
@@ -2234,7 +2234,7 @@ ELSE()
SET(SRCS ${SRCS})
ENDIF(ENABLE_TMWA)
-ADD_EXECUTABLE(manaplus WIN32 ${SRCS} ${SRCS_EVOL})
+ADD_EXECUTABLE(manaverse WIN32 ${SRCS} ${SRCS_EVOL})
#ADD_EXECUTABLE(dyecmd WIN32 ${DYE_CMD_SRCS})
IF (USE_SDL2)
@@ -2255,7 +2255,7 @@ ELSE()
${SDLTTF_LIBRARY})
ENDIF (USE_SDL2)
-TARGET_LINK_LIBRARIES(manaplus
+TARGET_LINK_LIBRARIES(manaverse
${X11_LIBRARIES}
${SDL_LIBS}
${PNG_LIBRARIES}
@@ -2265,7 +2265,7 @@ TARGET_LINK_LIBRARIES(manaplus
${OPENGL_LIBRARIES}
${LIBINTL_LIBRARIES}
${EXTRA_LIBRARIES})
-INSTALL(TARGETS manaplus RUNTIME DESTINATION ${PKG_BINDIR})
+INSTALL(TARGETS manaverse RUNTIME DESTINATION ${PKG_BINDIR})
#TARGET_LINK_LIBRARIES(dyecmd
# ${SDLGFX_LIBRARIES}
@@ -2286,9 +2286,9 @@ INSTALL(TARGETS manaplus RUNTIME DESTINATION ${PKG_BINDIR})
IF (CMAKE_SYSTEM_NAME STREQUAL SunOS)
# we expect the SMCgtxt package to be present on Solaris;
# the Solaris gettext is not API-compatible to GNU gettext
- SET_TARGET_PROPERTIES(manaplus PROPERTIES LINK_FLAGS "-L/usr/local/lib")
+ SET_TARGET_PROPERTIES(manaverse PROPERTIES LINK_FLAGS "-L/usr/local/lib")
# SET_TARGET_PROPERTIES(dyecmd PROPERTIES LINK_FLAGS "-L/usr/local/lib")
ENDIF()
-SET_TARGET_PROPERTIES(manaplus PROPERTIES COMPILE_FLAGS "${FLAGS}")
+SET_TARGET_PROPERTIES(manaverse PROPERTIES COMPILE_FLAGS "${FLAGS}")
#SET_TARGET_PROPERTIES(dyecmd PROPERTIES COMPILE_FLAGS "${DYE_FLAGS}")