summaryrefslogtreecommitdiff
path: root/src/char_sql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/char_sql/CMakeLists.txt')
-rw-r--r--src/char_sql/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/char_sql/CMakeLists.txt b/src/char_sql/CMakeLists.txt
index 7d3b7ad7e..f2d1cd0f0 100644
--- a/src/char_sql/CMakeLists.txt
+++ b/src/char_sql/CMakeLists.txt
@@ -42,10 +42,11 @@ add_executable( char-server_sql ${SOURCE_FILES} )
add_dependencies( char-server_sql ${DEPENDENCIES} )
target_link_libraries( char-server_sql ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( char-server_sql PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
-if( INSTALL_RUN_DATA )
+if( WITH_COMPONENT_RUNTIME )
+ cpack_add_component( Runtime_charserver_sql DESCRIPTION "char-server (sql version)" DISPLAY_NAME "char-server_sql" GROUP Runtime )
install( TARGETS char-server_sql
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- COMPONENT "char-server_sql" )
+ DESTINATION "."
+ COMPONENT Runtime_charserver_sql )
endif()
message( STATUS "Creating target char-server_sql - done" )
set( HAVE_char-server_sql ON CACHE BOOL "char-server_sql target is available" )