summaryrefslogtreecommitdiff
path: root/src/char/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/char/CMakeLists.txt')
-rw-r--r--src/char/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/char/CMakeLists.txt b/src/char/CMakeLists.txt
index 1f6f1ea11..9e0cbd9f4 100644
--- a/src/char/CMakeLists.txt
+++ b/src/char/CMakeLists.txt
@@ -36,10 +36,11 @@ add_executable( char-server ${SOURCE_FILES} )
add_dependencies( char-server ${DEPENDENCIES} )
target_link_libraries( char-server ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( char-server PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
-if( INSTALL_RUN_DATA )
+if( WITH_COMPONENT_RUNTIME )
+ cpack_add_component( Runtime_charserver_txt DESCRIPTION "char-server (txt version)" DISPLAY_NAME "char-server" GROUP Runtime )
install( TARGETS char-server
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- COMPONENT "char-server" )
+ DESTINATION "."
+ COMPONENT Runtime_charserver_txt )
endif()
message( STATUS "Creating target char-server - done" )
set( HAVE_char-server ON CACHE BOOL "char-server target is available" )