summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.in b/configure.in
index a9e4c289a..3aff089db 100644
--- a/configure.in
+++ b/configure.in
@@ -440,42 +440,6 @@ AC_COMPILE_IFELSE(
)
-#
-# DB_MANUAL_CAST_TO_UNION
-#
-AC_MSG_CHECKING([whether $CC is able to typecast to union])
-AC_COMPILE_IFELSE(
- [
- typedef union Foonion
- {
- int i;
- unsigned int ui;
- const char* s;
- }
- Foonion;
-
- int bar(Foonion onion)
- {
- return onion.i;
- }
-
- int foo(void)
- {
- int i = 0;
-
- return bar(((Foonion)(int)i));
- }
- ],
- [
- AC_MSG_RESULT([yes])
- ],
- [
- AC_MSG_RESULT([no])
- CFLAGS="$CFLAGS -DDB_MANUAL_CAST_TO_UNION"
- ]
-)
-
-
###############################################################################
# Check for libraries and header files.
#