summaryrefslogtreecommitdiff
path: root/src/map/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-07 03:21:42 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-07 03:21:42 +0000
commit76d7c8ad887ac7b9dfdb495fe26ef8d4d8dfe370 (patch)
tree053d4d29a26693e1714f3e44383b8c2b1ac7199f /src/map/sql/CMakeLists.txt
parent482beafefb9c50e5c1d3d16fd69b88cf2c9e84db (diff)
downloadhercules-76d7c8ad887ac7b9dfdb495fe26ef8d4d8dfe370.tar.gz
hercules-76d7c8ad887ac7b9dfdb495fe26ef8d4d8dfe370.tar.bz2
hercules-76d7c8ad887ac7b9dfdb495fe26ef8d4d8dfe370.tar.xz
hercules-76d7c8ad887ac7b9dfdb495fe26ef8d4d8dfe370.zip
* CMake: normalized variable names, added ability to create a package/installer.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14890 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/map/sql/CMakeLists.txt')
-rw-r--r--src/map/sql/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/map/sql/CMakeLists.txt b/src/map/sql/CMakeLists.txt
index c7922f276..74598423a 100644
--- a/src/map/sql/CMakeLists.txt
+++ b/src/map/sql/CMakeLists.txt
@@ -81,7 +81,7 @@ set( DEPENDENCIES common_sql )
set( LIBRARIES ${GLOBAL_LIBRARIES} )
set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} )
set( DEFINITIONS ${GLOBAL_DEFINITIONS} )
-if( USE_PCRE )
+if( WITH_PCRE )
message( STATUS "Using PCRE" )
list( APPEND LIBRARIES ${PCRE_LIBRARIES} )
list( APPEND INCLUDE_DIRS ${PCRE_INCLUDE_DIRS} )
@@ -95,10 +95,11 @@ add_executable( map-server_sql ${SOURCE_FILES} )
add_dependencies( map-server_sql ${DEPENDENCIES} )
target_link_libraries( map-server_sql ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( map-server_sql PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
-if( INSTALL_RUN_DATA )
+if( WITH_COMPONENT_RUNTIME )
+ cpack_add_component( Runtime_mapserver_sql DESCRIPTION "map-server (sql version)" DISPLAY_NAME "map-server_sql" GROUP Runtime )
install( TARGETS map-server_sql
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- COMPONENT "map-server_sql" )
+ DESTINATION "."
+ COMPONENT Runtime_mapserver_sql )
endif()
message( STATUS "Creating target map-server_sql - done" )
set( HAVE_map-server_sql ON CACHE BOOL "map-server_sql target is available" )