summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorblacksirius <blacksirius@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-06-01 14:21:02 +0000
committerblacksirius <blacksirius@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-06-01 14:21:02 +0000
commit18ac48230ab17ee05ed4b717d858a20879f851f9 (patch)
treeb30e993c0a14a09fe70586570a97ed7d2a90a21c /configure.in
parent673164238ca72b5d90c6ad0df00f509d339a0621 (diff)
downloadhercules-18ac48230ab17ee05ed4b717d858a20879f851f9.tar.gz
hercules-18ac48230ab17ee05ed4b717d858a20879f851f9.tar.bz2
hercules-18ac48230ab17ee05ed4b717d858a20879f851f9.tar.xz
hercules-18ac48230ab17ee05ed4b717d858a20879f851f9.zip
removed the old obsolete Plugin system (commit 1/2)
- Removed @ Autoconf/make and CMake, VC Projects will be cleaned in a additional commit. git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@16203 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 1 insertions, 51 deletions
diff --git a/configure.in b/configure.in
index 5d5811134..ef029bcd5 100644
--- a/configure.in
+++ b/configure.in
@@ -8,7 +8,7 @@ AC_CONFIG_SRCDIR([src/common/cbasetypes.h])
AC_CONFIG_FILES([Makefile src/common/Makefile])
AC_CONFIG_FILES([3rdparty/mt19937ar/Makefile 3rdparty/libconfig/Makefile])
AC_CONFIG_FILES([src/char/Makefile src/login/Makefile])
-AC_CONFIG_FILES([src/map/Makefile src/plugins/Makefile src/tool/Makefile])
+AC_CONFIG_FILES([src/map/Makefile src/tool/Makefile])
AC_GNU_SOURCE
@@ -445,56 +445,6 @@ CFLAGS="$OLD_CFLAGS"
#
-# -shared needs position independent code; some platforms emit it
-# always, others need -fPIC
-#
-AC_MSG_CHECKING([whether $CC needs -fPIC for shared objects])
-OLD_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS -shared"
-WITH_PLUGINS="yes"
-AC_LINK_IFELSE(
- [
- int foo(void)
- {
- return 0;
- }
- ],
- [
- AC_MSG_RESULT([no])
- CFLAGS="$OLD_CFLAGS"
- ],
- [
- if test "$compiler_supports_pic" = "yes" ; then
- # Verify if -shared really fails due to lack of -fPIC or something else
- CFLAGS="$CFLAGS -fPIC"
- AC_LINK_IFELSE(
- [
- int foo(void)
- {
- return 0;
- }
- ],
- [
- AC_MSG_RESULT([yes])
- CFLAGS="$OLD_CFLAGS -fPIC"
- ],
- [
- AC_MSG_RESULT([no, but fails for another reason])
- AC_MSG_ERROR([compiler is unable to compile shared objects for an unhandled reason, please report this with attached config.log... stopping])
- ]
- )
- else
- # Disable compilation of plugins (optional), so 'make all' does not fail
- AC_MSG_RESULT([yes, but unsupported])
- AC_MSG_NOTICE([compiler is unable to generate position independent code, disabled plugins (optional)])
- WITH_PLUGINS="no"
- fi
- ]
-)
-AC_SUBST([WITH_PLUGINS])
-
-
-#
# -O2 implies -fstrict-aliasing, but the code is not safe for that
#
AC_MSG_CHECKING([whether $CC supports -fno-strict-aliasing])