summaryrefslogtreecommitdiff
path: root/3rdparty/libconfig/extra/configure.ac
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2013-09-09 13:23:29 +0200
committerHaru <haru@dotalux.com>2013-09-17 01:56:14 +0200
commite6a9f7cfdb5ee6d27c12d35f2ecf8317595317b6 (patch)
tree9b0a9a5b61c790ccbecc9c751e5cb6012edcd285 /3rdparty/libconfig/extra/configure.ac
parentb8bf9548d76a46650b8559d621e81072d340bc04 (diff)
downloadhercules-e6a9f7cfdb5ee6d27c12d35f2ecf8317595317b6.tar.gz
hercules-e6a9f7cfdb5ee6d27c12d35f2ecf8317595317b6.tar.bz2
hercules-e6a9f7cfdb5ee6d27c12d35f2ecf8317595317b6.tar.xz
hercules-e6a9f7cfdb5ee6d27c12d35f2ecf8317595317b6.zip
Re-generated libconfig parser and scanner
This overrides previous manual edits to the machine-generated files, and is supposed to make it much easier to maintain in future. There should be no functional changes at all, but if there's any issue, please let me know. Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to '3rdparty/libconfig/extra/configure.ac')
-rw-r--r--3rdparty/libconfig/extra/configure.ac79
1 files changed, 79 insertions, 0 deletions
diff --git a/3rdparty/libconfig/extra/configure.ac b/3rdparty/libconfig/extra/configure.ac
new file mode 100644
index 000000000..622abb3e2
--- /dev/null
+++ b/3rdparty/libconfig/extra/configure.ac
@@ -0,0 +1,79 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(libconfig, 1.4.9, hyperrealm@gmail.com, libconfig,
+ [http://www.hyperrealm.com/main.php?s=libconfig])
+#AC_CANONICAL_TARGET
+
+AC_MSG_NOTICE([libconfig - made with pride in California])
+
+AC_PROG_MAKE_SET
+
+AC_DEFINE_UNQUOTED(TARGET, "${target}", [Configured target name.])
+
+# Enable GNU extensions.
+AC_GNU_SOURCE
+
+dnl Checks for programs.
+AC_PROG_CC
+
+AC_PROG_LEX
+if test Z"$LEX" != Zflex; then
+cat <<EOF
+*******************************************************************
+You do not seem to have flex. While flex is not required to build
+libconfig, you may need it to regenerate the lexer if you change
+the scanner.l file. Flex 2.5.33 or newer is recommended.
+*******************************************************************
+EOF
+fi
+
+AC_PROG_YACC
+if test Z"$YACC" != "Zbison -y"; then
+cat <<EOF
+*******************************************************************
+You do not seem to have bison. While bison is not required to build
+libconfig, you may need it to regenerate the parser if you change
+the grammar.y file.
+*******************************************************************
+EOF
+fi
+
+AC_MSG_CHECKING([for compiler switch to enable full C/C++ warnings]);
+
+dnl Checks for libraries
+
+dnl Enable warnings, if we can determine an appropriate switch...
+case "${CC}" in
+
+gcc)
+ warn_c_sw="-Wall -Wshadow -Wextra -Wdeclaration-after-statement -Wno-unused-parameter";;
+*)
+ warn_c_sw="";;
+esac
+
+if test -n "${warn_c_sw}";
+then
+ CFLAGS="${CFLAGS} ${warn_c_sw}";
+ AC_MSG_RESULT([${warn_c_sw}])
+else
+ AC_MSG_RESULT([(cannot determine)])
+fi;
+
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(unistd.h stdint.h xlocale.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+
+dnl Checks for functions
+
+AC_CHECK_FUNCS([newlocale uselocale freelocale])
+
+dnl Checks for library functions.
+
+AC_OUTPUT(
+ doc/Makefile
+ gen/Makefile
+ )