summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f922d99..1f8435b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,26 @@ AC_ARG_ENABLE(
)
AM_CONDITIONAL(ENABLE_STATIC, test x$enable_static = xyes)
+AC_ARG_ENABLE(
+ [gprof],
+ AC_HELP_STRING(
+ [--enable-gprof],
+ [
+ Enables or Disables Gprof (disabled by default)
+ ]
+ ),
+ [
+ enable_gprof="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-gprof=$disableval... stopping]]);;
+ esac
+ ],
+ [enable_gprof="no"]
+)
+AM_CONDITIONAL(ENABLE_GPROF, test x$enable_gprof = xyes)
+
AC_CHECK_FUNC([strnlen],[CFLAGS="$CFLAGS -DHAVE_STRNLEN"])
AC_CHECK_FUNC([setrlimit],[CLAGS="$CFLAGS -DHAVE_SETRLIMIT"])