summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-02-21 20:13:47 +0300
committerAndrei Karas <akaras@inbox.ru>2016-02-21 20:59:20 +0300
commitfabe15b29d7db7823568548da998b24e75f2cce8 (patch)
tree2d020720ae4c433c7e490b8c4f63cfe5ded3a6c5 /src/Makefile.am
parentc74d1843675c20f958fb71d2bdf9fd5c79fe835e (diff)
downloadevol-hercules-fabe15b29d7db7823568548da998b24e75f2cce8.tar.gz
evol-hercules-fabe15b29d7db7823568548da998b24e75f2cce8.tar.bz2
evol-hercules-fabe15b29d7db7823568548da998b24e75f2cce8.tar.xz
evol-hercules-fabe15b29d7db7823568548da998b24e75f2cce8.zip
Add same compiler flags what was used in hercules.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7488e03..c32927f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -108,7 +108,7 @@ MAP_SRC = emap/atcommand.c \
# need remove -Wno-unused
-SHARED_CFLAGS = -pipe -ffast-math -fvisibility=hidden -rdynamic -std=gnu90 -Wall -Wextra -Wno-sign-compare -Wno-unused \
+SHARED_CFLAGS = ${CFLAGS} -pipe -ffast-math -fvisibility=hidden -rdynamic -std=c99 -Wall -Wextra -Wno-sign-compare -Wno-unused \
-DPCRE_SUPPORT -I../../.. -I../../../../3rdparty -DPACKETVER=20150000
SHARED_LDFLAGS = -avoid-version -Wl,--no-undefined