summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-08-19 16:37:11 +0300
committerAndrei Karas <akaras@inbox.ru>2015-08-19 16:55:16 +0300
commitb95b22472c0ddc0ccacd10928437bd245b016f99 (patch)
tree323f490973f6a8dd0aa3a57c666e2f9b2f885066 /src/Makefile.am
parent9462476364311b17a4ab34547a102e2228ef9c57 (diff)
downloadevol-hercules-b95b22472c0ddc0ccacd10928437bd245b016f99.tar.gz
evol-hercules-b95b22472c0ddc0ccacd10928437bd245b016f99.tar.bz2
evol-hercules-b95b22472c0ddc0ccacd10928437bd245b016f99.tar.xz
evol-hercules-b95b22472c0ddc0ccacd10928437bd245b016f99.zip
Enforce gnu90 standard.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b5ff844..f17f16a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -85,7 +85,7 @@ MAP_SRC = emap/atcommand.c \
# need remove -Wno-unused
-SHARED_CFLAGS = -pipe -ffast-math -fvisibility=hidden -rdynamic -Wall -Wextra -Wno-sign-compare -Wno-unused \
+SHARED_CFLAGS = -pipe -ffast-math -fvisibility=hidden -rdynamic -std=gnu90 -Wall -Wextra -Wno-sign-compare -Wno-unused \
-DPCRE_SUPPORT -I../../.. -I../../../../3rdparty -DPACKETVER=20150000
SHARED_LDFLAGS = -avoid-version -Wl,--no-undefined