summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-04-28 00:02:24 +0300
committerAndrei Karas <akaras@inbox.ru>2016-04-28 00:04:40 +0300
commit6fd8ab7369fcd4e119b6ff624ccadb3bcc542411 (patch)
tree77942c3677d855a9c4c93e3c1b12feabfb3e491f /src/Makefile.am
parent457e6e04f2f8c4b0ce5f73db8c17a2fe3c3951ed (diff)
downloadevol-hercules-6fd8ab7369fcd4e119b6ff624ccadb3bcc542411.tar.gz
evol-hercules-6fd8ab7369fcd4e119b6ff624ccadb3bcc542411.tar.bz2
evol-hercules-6fd8ab7369fcd4e119b6ff624ccadb3bcc542411.tar.xz
evol-hercules-6fd8ab7369fcd4e119b6ff624ccadb3bcc542411.zip
Add configure flag --enable-werror.
If enabled it will report any warning as error.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index afd8435..56c6887 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -142,6 +142,10 @@ if ENABLE_GPROF
SHARED_CFLAGS += "-pg"
endif
+if ENABLE_WERROR
+SHARED_CFLAGS += "-Werror"
+endif
+
lib_LTLIBRARIES = libevol_char.la libevol_login.la libevol_map.la
libevol_char_la_SOURCES = ${CHAR_SRC}
libevol_char_la_LDFLAGS = ${SHARED_LDFLAGS}