summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-08-10 14:50:09 +0300
committerAndrei Karas <akaras@inbox.ru>2015-08-16 15:52:35 +0300
commit38c48c78eb1d5822565504363863918e39e0cd4a (patch)
tree740ed3f18baff57e0ac33e6e8405d217546429d3 /src/Makefile.am
parent2ed4142dfcde097648857f41f8064b0a19c350c7 (diff)
downloadevol-hercules-38c48c78eb1d5822565504363863918e39e0cd4a.tar.gz
evol-hercules-38c48c78eb1d5822565504363863918e39e0cd4a.tar.bz2
evol-hercules-38c48c78eb1d5822565504363863918e39e0cd4a.tar.xz
evol-hercules-38c48c78eb1d5822565504363863918e39e0cd4a.zip
Fix compilation after HPM update in server.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 04c76a5..b5ff844 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -83,7 +83,9 @@ MAP_SRC = emap/atcommand.c \
ecommon/init.c \
ecommon/init.h
-SHARED_CFLAGS = -pipe -ffast-math -Wall -Wextra -Wno-sign-compare \
+# need remove -Wno-unused
+
+SHARED_CFLAGS = -pipe -ffast-math -fvisibility=hidden -rdynamic -Wall -Wextra -Wno-sign-compare -Wno-unused \
-DPCRE_SUPPORT -I../../.. -I../../../../3rdparty -DPACKETVER=20150000
SHARED_LDFLAGS = -avoid-version -Wl,--no-undefined