summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2014-11-06 20:57:29 +0300
committerAndrei Karas <akaras@inbox.ru>2014-11-07 00:35:13 +0300
commitd808fef992c2f37bd89fd8336f20cf587016e5a9 (patch)
tree2d390c3f544316b3713a9ba372aa3b0afa0667ce /src/Makefile.am
parentfeba0e8cd021ab0a0b469e79125dfc794442db17 (diff)
downloadevol-hercules-d808fef992c2f37bd89fd8336f20cf587016e5a9.tar.gz
evol-hercules-d808fef992c2f37bd89fd8336f20cf587016e5a9.tar.bz2
evol-hercules-d808fef992c2f37bd89fd8336f20cf587016e5a9.tar.xz
evol-hercules-d808fef992c2f37bd89fd8336f20cf587016e5a9.zip
Add packet for accept client version in map server.
Add struct for additional connection data. Add functions for get additional connection data. Impliment script function: getclientversion.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 64eece0..dd1268b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,8 +9,13 @@ LOGIN_SRC = login/init.c \
MAP_SRC = map/dummy.c \
map/dummy.h \
map/init.c \
+ map/parse.c \
+ map/parse.h \
map/script.c \
- map/script.h
+ map/script.h \
+ map/session.c \
+ map/session.h \
+ map/sessionext.h
SHARED_FLAGS = -pipe -ffast-math -Wall -Wextra -Wno-sign-compare -fsanitize=address