summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2014-11-13 17:36:57 +0300
committerAndrei Karas <akaras@inbox.ru>2014-11-13 17:36:57 +0300
commitc55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51 (patch)
tree81481e7e4871d65ce22d1945efe22386689e6423 /configure.ac
parent0e184a35c76ac02d58467da556e665cd45083557 (diff)
downloadevol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.tar.gz
evol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.tar.bz2
evol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.tar.xz
evol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.zip
Add configure option --enable-sanitize.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f21bc47..1ed1511 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,26 @@ AC_ENABLE_SHARED
AC_DISABLE_STATIC
AC_ARG_ENABLE(
+ [sanitize],
+ AC_HELP_STRING(
+ [--enable-sanitize],
+ [
+ Enables or Disables Sanitize Address Checking (SANITIZE is disabled by default)
+ ]
+ ),
+ [
+ enable_sanitize="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-sanitize=$disableval... stopping]]);;
+ esac
+ ],
+ [enable_sanitize="no"]
+)
+AM_CONDITIONAL(ENABLE_SANITIZE, test x$enable_sanitize = xyes)
+
+AC_ARG_ENABLE(
[static],
AC_HELP_STRING(
[--enable-static],