summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt46
1 files changed, 30 insertions, 16 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 38589505..bc44a05c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -301,8 +301,6 @@ SET(SRCS
gui/textdialog.h
gui/textpopup.cpp
gui/textpopup.h
- gui/theme.cpp
- gui/theme.h
gui/trade.cpp
gui/trade.h
gui/truetypefont.cpp
@@ -311,8 +309,6 @@ SET(SRCS
gui/unregisterdialog.h
gui/updatewindow.cpp
gui/updatewindow.h
- gui/userpalette.cpp
- gui/userpalette.h
gui/viewport.cpp
gui/viewport.h
gui/windowmenu.cpp
@@ -353,6 +349,8 @@ SET(SRCS
resources/ambientoverlay.h
resources/animation.cpp
resources/animation.h
+ resources/beinginfo.cpp
+ resources/beinginfo.h
resources/colordb.cpp
resources/colordb.h
resources/dye.cpp
@@ -375,8 +373,6 @@ SET(SRCS
resources/mapreader.h
resources/monsterdb.cpp
resources/monsterdb.h
- resources/monsterinfo.cpp
- resources/monsterinfo.h
resources/music.cpp
resources/music.h
resources/npcdb.cpp
@@ -387,8 +383,14 @@ SET(SRCS
resources/resourcemanager.h
resources/soundeffect.h
resources/soundeffect.cpp
+ resources/specialdb.cpp
+ resources/specialdb.h
resources/spritedef.h
resources/spritedef.cpp
+ resources/theme.cpp
+ resources/theme.h
+ resources/userpalette.cpp
+ resources/userpalette.h
resources/wallpaper.cpp
resources/wallpaper.h
utils/base64.cpp
@@ -409,6 +411,12 @@ SET(SRCS
utils/xml.h
utils/zlib.cpp
utils/zlib.h
+ actor.cpp
+ actor.h
+ actorsprite.cpp
+ actorsprite.h
+ actorspritemanager.cpp
+ actorspritemanager.h
animatedsprite.cpp
animatedsprite.h
animationparticle.cpp
@@ -417,8 +425,8 @@ SET(SRCS
avatar.h
being.cpp
being.h
- beingmanager.cpp
- beingmanager.h
+ chatlog.cpp
+ chatlog.h
client.cpp
client.h
channel.cpp
@@ -427,18 +435,22 @@ SET(SRCS
channelmanager.h
commandhandler.cpp
commandhandler.h
+ compoundsprite.cpp
+ compoundsprite.h
configlistener.h
configuration.cpp
configuration.h
+ defaults.cpp
+ defaults.h
effectmanager.cpp
effectmanager.h
emoteshortcut.cpp
emoteshortcut.h
equipment.h
+ event.cpp
+ event.h
flooritem.cpp
flooritem.h
- flooritemmanager.cpp
- flooritemmanager.h
game.cpp
game.h
graphics.cpp
@@ -448,6 +460,8 @@ SET(SRCS
guild.h
imageparticle.cpp
imageparticle.h
+ imagesprite.cpp
+ imagesprite.h
inventory.cpp
inventory.h
item.cpp
@@ -458,6 +472,8 @@ SET(SRCS
joystick.h
keyboardconfig.cpp
keyboardconfig.h
+ listener.cpp
+ listener.h
localplayer.cpp
localplayer.h
log.cpp
@@ -466,10 +482,6 @@ SET(SRCS
main.h
map.cpp
map.h
- monster.cpp
- monster.h
- npc.cpp
- npc.h
openglgraphics.cpp
openglgraphics.h
particle.cpp
@@ -481,8 +493,8 @@ SET(SRCS
particleemitterprop.h
party.cpp
party.h
- player.cpp
- player.h
+ playerinfo.cpp
+ playerinfo.h
playerrelations.cpp
playerrelations.h
position.cpp
@@ -509,6 +521,7 @@ SET(SRCS
tileset.h
units.cpp
units.h
+ variabledata.h
vector.cpp
vector.h
)
@@ -575,6 +588,7 @@ SET(SRCS_MANA
net/manaserv/chathandler.h
net/manaserv/connection.cpp
net/manaserv/connection.h
+ net/manaserv/defines.h
net/manaserv/effecthandler.cpp
net/manaserv/effecthandler.h
net/manaserv/gamehandler.cpp