summaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 1c634a89..93d94f3a 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,4 +1,13 @@
FIND_PACKAGE(Gettext REQUIRED)
FILE(GLOB POFILES *.po)
-GETTEXT_CREATE_TRANSLATIONS(tmw.pot ${POFILES}) \ No newline at end of file
+GETTEXT_CREATE_TRANSLATIONS(tmw.pot ${POFILES})
+# This is an ugly hack to enable building of translations with
+# the default target due to a bug in GETTEXT_CREATE_TRANSLATIONS.
+# The bug has been fixed in recent CMake 2.6.3. Once 2.6.3 is widely
+# deployed the above line should be changed to:
+# GETTEXT_CREATE_TRANSLATIONS(tmw.pot ALL ${POFILES})
+# and the following two lines removed
+# 2009-04-08 Bernd Wachter <bwachter-tmw@lart.info>
+ADD_CUSTOM_TARGET(transfix ALL)
+ADD_DEPENDENCIES(transfix translations)