summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b39ddc7e..1beb2ea6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,7 @@ find_package(Gettext)
option(WITH_OPENGL "Enable OpenGL support" ON)
option(ENABLE_NLS "Enable building of translations" ON)
option(ENABLE_MANASERV "Enable Manaserv support" ON)
+option(USE_SYSTEM_ENET "Use system ENet" OFF)
option(USE_SYSTEM_GUICHAN "Use system Guichan" ON)
if(WIN32)
@@ -49,8 +50,8 @@ include(GNUInstallDirs)
add_subdirectory(data)
-if(ENABLE_MANASERV)
- add_subdirectory(libs/enet)
+if(ENABLE_MANASERV AND NOT USE_SYSTEM_ENET)
+ add_subdirectory(libs/enet EXCLUDE_FROM_ALL)
endif()
# On macOS we need to build Guichan ourselves since it is disabled in Homebrew