summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2009-04-10 02:20:04 +0200
committerBjørn Lindeijer <bjorn@lindeijer.nl>2009-04-10 02:27:44 +0200
commit33afe8f744587b9a8da67e85298bb2e1c28d083d (patch)
tree807981f32e1f73da6f8719631b46fd493a0e7ae3 /src/Makefile.am
parent07e8a1b8408ed40cbf2031476627647057f62141 (diff)
downloadmana-33afe8f744587b9a8da67e85298bb2e1c28d083d.tar.gz
mana-33afe8f744587b9a8da67e85298bb2e1c28d083d.tar.bz2
mana-33afe8f744587b9a8da67e85298bb2e1c28d083d.tar.xz
mana-33afe8f744587b9a8da67e85298bb2e1c28d083d.zip
Reduced the GCContainer to be even more trivial
A container that deletes all its children on destruction doesn't have to be so complicated. Also renamed it to simply Container, since I think it should simply be default behavior. WindowContainer and Popup classes now inherit from this Container.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e13299f0..6bef1960 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,12 +17,12 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/widgets/chattab.h \
gui/widgets/checkbox.cpp \
gui/widgets/checkbox.h \
+ gui/widgets/container.cpp \
+ gui/widgets/container.h \
gui/widgets/desktop.cpp \
gui/widgets/desktop.h \
gui/widgets/dropdown.cpp \
gui/widgets/dropdown.h \
- gui/widgets/gccontainer.cpp \
- gui/widgets/gccontainer.h \
gui/widgets/icon.cpp \
gui/widgets/icon.h \
gui/widgets/inttextfield.cpp \