summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAaron Marks <nymacro@gmail.com>2005-07-08 09:47:06 +0000
committerAaron Marks <nymacro@gmail.com>2005-07-08 09:47:06 +0000
commite7d0e1f6bc3a1583cc72b3fe5230a5bcb2e63f1d (patch)
tree40e206c03c586e77baf8fe018922c59757abded8 /src/Makefile.am
parentad1fd6ad07e25b7fa4937cb28f9371371fbd83be (diff)
downloadmana-e7d0e1f6bc3a1583cc72b3fe5230a5bcb2e63f1d.tar.gz
mana-e7d0e1f6bc3a1583cc72b3fe5230a5bcb2e63f1d.tar.bz2
mana-e7d0e1f6bc3a1583cc72b3fe5230a5bcb2e63f1d.tar.xz
mana-e7d0e1f6bc3a1583cc72b3fe5230a5bcb2e63f1d.zip
Added basic update system (depends on curl).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b1fe75c5..74b1383f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -99,6 +99,8 @@ tmw_SOURCES = graphic/spriteset.cpp \
gui/vbox.cpp \
gui/hbox.h \
gui/hbox.cpp \
+ gui/updatewindow.h \
+ gui/updatewindow.cpp \
net/network.cpp \
net/network.h \
net/protocol.cpp \
@@ -152,6 +154,6 @@ INCLUDES = \
# the library search path.
tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) `pkg-config --libs libxml-2.0`
-tmw_CXXFLAGS = -Wall $(OPENGL_CFLAGS) $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0`
-tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl -lguichan $(OPENGL_LIBS) -lphysfs
+tmw_CXXFLAGS = -Wall $(OPENGL_CFLAGS) $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0` $(CURL_CFLAGS)
+tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl -lguichan $(OPENGL_LIBS) -lphysfs $(CURL_LIBS)
tmw_TARGET = tmw