summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-03-30 20:44:45 +0100
committerThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-04-08 16:29:46 +0200
commit0e493346b8ca9842946343ef43af1fbe2fd85fce (patch)
tree40361bcfb687af76a919b51a90305ba4c7e8cb5e /src/CMakeLists.txt
parentdc99410902b9eade9e408389e49f09d5163b6caf (diff)
downloadmana-0e493346b8ca9842946343ef43af1fbe2fd85fce.tar.gz
mana-0e493346b8ca9842946343ef43af1fbe2fd85fce.tar.bz2
mana-0e493346b8ca9842946343ef43af1fbe2fd85fce.tar.xz
mana-0e493346b8ca9842946343ef43af1fbe2fd85fce.zip
Resolved issues with winver.h
The configured file wasn't actually being used, because it was not in the include path. Instead, a checked in version was used. In addition, winver.h is an existing Windows header, which was conflicting with the generated file. Instead, now mana.rc itself is configured. We didn't actually need winver.h anywhere else, anyway.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e57d5e3f..91afadb1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -622,11 +622,12 @@ SET(SRCS_MANA
)
IF (WIN32)
+ CONFIGURE_FILE(mana.rc.in mana.rc)
SET(SRCS
${SRCS}
utils/specialfolder.cpp
utils/specialfolder.h
- mana.rc
+ ${CMAKE_CURRENT_BINARY_DIR}/mana.rc
)
ENDIF (WIN32)