summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorYohann Ferreira <yohann_dot_ferreira_at_orange_dot_efer>2011-11-21 21:07:59 +0100
committerYohann Ferreira <yohann_dot_ferreira_at_orange_dot_efer>2012-01-10 20:31:56 +0100
commit98be39a094cc20f513da1847c553513682e4eeae (patch)
treebf3ac3591cf80c14e484328d50d7b553d18244e2 /src/CMakeLists.txt
parent683da50e37fbbb2e3f70a4421a06dabd9bb912d8 (diff)
downloadmana-98be39a094cc20f513da1847c553513682e4eeae.tar.gz
mana-98be39a094cc20f513da1847c553513682e4eeae.tar.bz2
mana-98be39a094cc20f513da1847c553513682e4eeae.tar.xz
mana-98be39a094cc20f513da1847c553513682e4eeae.zip
Made addition of custom servers be done in a separate window.
Now the first window the user can see is a list of servers which can double-clicked, making it all less cluttered. This commit also makes custom servers able to now have their own titles and their own description, just as the official ones. I also fixed the add entry button being registered twice to the action listener, and the fact that the description wasn't updated properly at windows loading and when adding/removing an entry. Resolves: Mana-Mantis #237. Reviewed-by: Ablu
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f4f50eff..42279239 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -233,6 +233,8 @@ SET(SRCS
gui/confirmdialog.h
gui/connectiondialog.cpp
gui/connectiondialog.h
+ gui/customserverdialog.cpp
+ gui/customserverdialog.h
gui/debugwindow.cpp
gui/debugwindow.h
gui/emotepopup.cpp