summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-05-07 10:44:56 +0200
committerThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-05-07 11:25:24 +0200
commit3f5377d6810de412c8963414f66f472fc740cad9 (patch)
tree042266942978c672ae879f8964772ed524d29880 /CMakeLists.txt
parentafbfb8b5792fb1e8b8bf5777576680f1a4f0cd08 (diff)
downloadmana-3f5377d6810de412c8963414f66f472fc740cad9.tar.gz
mana-3f5377d6810de412c8963414f66f472fc740cad9.tar.bz2
mana-3f5377d6810de412c8963414f66f472fc740cad9.tar.xz
mana-3f5377d6810de412c8963414f66f472fc740cad9.zip
Replaced ENet with submodule
This also updates ENet from 1.3.2 to 1.3.18. The previously supported WITH_BUNDLEDHEADERS option that affected which ENet was being used has now been reversed and renamed to USE_SYSTEM_ENET, which defaults to OFF for now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b39ddc7e..1beb2ea6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,7 @@ find_package(Gettext)
option(WITH_OPENGL "Enable OpenGL support" ON)
option(ENABLE_NLS "Enable building of translations" ON)
option(ENABLE_MANASERV "Enable Manaserv support" ON)
+option(USE_SYSTEM_ENET "Use system ENet" OFF)
option(USE_SYSTEM_GUICHAN "Use system Guichan" ON)
if(WIN32)
@@ -49,8 +50,8 @@ include(GNUInstallDirs)
add_subdirectory(data)
-if(ENABLE_MANASERV)
- add_subdirectory(libs/enet)
+if(ENABLE_MANASERV AND NOT USE_SYSTEM_ENET)
+ add_subdirectory(libs/enet EXCLUDE_FROM_ALL)
endif()
# On macOS we need to build Guichan ourselves since it is disabled in Homebrew