summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9674e0e2b..d5a37af0f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -95,6 +95,10 @@ endif
if ENABLE_TINYXML2
manaplus_CXXFLAGS += -DENABLE_TINYXML2
dyecmd_CXXFLAGS += -DENABLE_TINYXML2
+if USE_TINYXML_OLD
+manaplus_CXXFLAGS += -DUSE_TINYXML_OLD
+dyecmd_CXXFLAGS += -DUSE_TINYXML_OLD
+endif
endif
if ENABLE_PORTABLE
@@ -2048,6 +2052,9 @@ manaplustests_CXXFLAGS += -DENABLE_LIBXML
endif
if ENABLE_TINYXML2
manaplustests_CXXFLAGS += -DENABLE_TINYXML2
+if USE_TINYXML_OLD
+manaplustests_CXXFLAGS += -DUSE_TINYXML_OLD
+endif
endif
if USE_SDL2
manaplustests_CXXFLAGS += -DUSE_SDL2