summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 73e6e97b3..367fa66cc 100755
--- a/configure.ac
+++ b/configure.ac
@@ -312,6 +312,17 @@ esac],[with_eathena=false])
AM_CONDITIONAL(ENABLE_EATHENA, test x$with_eathena = xtrue)
+# Enable checks
+AC_ARG_ENABLE(checks,
+[ --enable-checks Turn on internal checks (can be slow)],
+[case "${enableval}" in
+ yes) with_checks=true ;;
+ no) with_checks=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-checks) ;;
+esac],[with_checks=false])
+
+AM_CONDITIONAL(ENABLE_CHECKS, test x$with_checks = xtrue)
+
# Enable portable
AC_ARG_ENABLE(portable,
[ --enable-portable Turn on portable mode for linux],