summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dbf134319..d8abded8c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -368,6 +368,17 @@ esac],[googleprofiler_enabled=false])
AM_CONDITIONAL(ENABLE_GOOGLE_PROFILER, test x$googleprofiler_enabled = xtrue)
+# Enable cilk plus
+AC_ARG_ENABLE(cilkplus,
+[ --enable-cilkplus Turn on parallelisation with CilkPlus],
+[case "${enableval}" in
+ yes) cilkplus_enabled=true ;;
+ no) cilkplus_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-cilkplus) ;;
+esac],[cilkplus_enabled=false])
+
+AM_CONDITIONAL(ENABLE_CILKPLUS, test x$cilkplus_enabled = xtrue)
+
AC_CONFIG_FILES([
manaplus.spec
Makefile