summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7969baa0d..4df89a250 100755
--- a/configure.ac
+++ b/configure.ac
@@ -128,10 +128,18 @@ AC_TYPE_INT64_T
AC_TYPE_SSIZE_T
case $host in
- (*mingw*) skip_check_lib="yes" ;;
- (*) skip_check_lib="no"
+ (*mingw*)
+ skip_check_lib="yes"
+ mingw=true
+ ;;
+ (*)
+ skip_check_lib="no"
+ mingw=false
+ ;;
esac
+AM_CONDITIONAL(MINGW, test x$mingw = xtrue)
+
# Search for *-config
AC_PATH_PROG(PKG_CONFIG, pkg-config)
AC_PATH_PROG(CURL_CONFIG, curl-config)