summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d16fde20..ecc6ee35a 100755
--- a/configure.ac
+++ b/configure.ac
@@ -667,6 +667,15 @@ AM_CONDITIONAL(ENABLE_UNITTESTSBIN, test x$unittestsbin_enabled = xtrue)
AM_CONDITIONAL(ENABLE_UNITTESTSBIN_CATCH, test x$unittestsbin_catch = xtrue)
AM_CONDITIONAL(ENABLE_UNITTESTSBIN_DOCTEST, test x$unittestsbin_doctest = xtrue)
+# Override home directory for unit tests
+AC_ARG_WITH(unittestsdir,[ --with-unittestsdir override home directory for unit tests ] )
+if test "x$with_unittestsdir" == "xno"; then
+ with_unittestsdir=no
+else
+ with_unittestsdir=yes
+ CPPFLAGS="$CPPFLAGS -DUNITESTSDIR=$withval"
+fi
+
# Enable tcmalloc
AC_ARG_ENABLE(tcmalloc,
[ --enable-tcmalloc Turn on tcmalloc],