summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-07-08 00:59:36 +0300
committerAndrei Karas <akaras@inbox.ru>2017-07-08 00:59:36 +0300
commitc5a777d78b5eb4a829bb7aec76d7ce629f810bb8 (patch)
tree345e77da6b1add8220390729b5dc05bb4796f9b1 /src/Makefile.am
parentdf3ac31c7de4858c0575978e7a94595f21835463 (diff)
downloadplus-c5a777d78b5eb4a829bb7aec76d7ce629f810bb8.tar.gz
plus-c5a777d78b5eb4a829bb7aec76d7ce629f810bb8.tar.bz2
plus-c5a777d78b5eb4a829bb7aec76d7ce629f810bb8.tar.xz
plus-c5a777d78b5eb4a829bb7aec76d7ce629f810bb8.zip
Build at first unit tests files and after all other files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bb3f702e5..cf25f70b6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2009,7 +2009,7 @@ if ENABLE_OPENGLERRORS
manaplustests_CXXFLAGS += -DOPENGLERRORS
endif
-manaplustests_SOURCES = ${SRC} \
+manaplustests_SOURCES = \
unittests/unittests.h \
unittests/enums/render/mockdrawtype.h \
unittests/render/mockdrawitem.h \
@@ -2070,6 +2070,8 @@ manaplustests_SOURCES += \
unittests/resources/sdlimagehelper_unittest.cc \
unittests/gui/windowmanager_unittest.cc
+manaplustests_SOURCES += ${SRC}
+
if ENABLE_UNITTESTS
TESTS = manaplustests
check_PROGRAMS = manaplustests